summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 4 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index 9ab11b4..6cd9887 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,15 +1,10 @@
#!/usr/bin/make -f
-%:
- dh $@ --with=systemd
-
-override_dh_clean:
- dh_clean
- rm -f vanity
-override_dh_auto_configure:
+export DH_OPTIONS
+export DH_GOPKG := github.com/xiam/vanity
-override_dh_auto_build:
- go build -o vanity
+%:
+ dh $@ --buildsystem=golang --with=golang --with=systemd
override_dh_auto_install:
install -d $$(pwd)/debian/tmp/usr/bin/