summaryrefslogtreecommitdiff
path: root/serial-led/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'serial-led/CMakeLists.txt')
-rw-r--r--serial-led/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/serial-led/CMakeLists.txt b/serial-led/CMakeLists.txt
new file mode 100644
index 0000000..8ebe9a7
--- /dev/null
+++ b/serial-led/CMakeLists.txt
@@ -0,0 +1,37 @@
+##
+## spreadspace rppico utils
+##
+##
+## Copyright (C) 2022 Christian Pointner <equinox@spreadspace.org>
+##
+## This file is part of spreadspace rppico utils.
+##
+## spreadspace rppico utils is free software: you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation, either version 3 of the License, or
+## any later version.
+##
+## spreadspace rppico utils is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with spreadspace rppico utils. If not, see <http://www.gnu.org/licenses/>.
+##
+
+cmake_minimum_required(VERSION 3.12)
+include(../sdk.cmake)
+
+project(serial-led C CXX ASM)
+
+pico_sdk_init()
+
+add_compile_options(-Wall)
+
+add_executable(serial-led
+ serial-led.c
+ )
+
+target_link_libraries(serial-led pico_stdlib)
+pico_add_extra_outputs(serial-led)