summaryrefslogtreecommitdiff
path: root/sdk-blink/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sdk-blink/CMakeLists.txt')
-rw-r--r--sdk-blink/CMakeLists.txt33
1 files changed, 23 insertions, 10 deletions
diff --git a/sdk-blink/CMakeLists.txt b/sdk-blink/CMakeLists.txt
index c365501..85c5ad4 100644
--- a/sdk-blink/CMakeLists.txt
+++ b/sdk-blink/CMakeLists.txt
@@ -1,25 +1,38 @@
+##
+## spreadspace rppico utils
+##
+##
+## Copyright (C) 2022 Christian Pointner <equinox@spreadspace.org>
+##
+## This file is part of spreadspace rppico utils.
+##
+## spreadspace rppico utils is free software: you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation, either version 3 of the License, or
+## any later version.
+##
+## spreadspace rppico utils is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with spreadspace rppico utils. If not, see <http://www.gnu.org/licenses/>.
+##
+
cmake_minimum_required(VERSION 3.12)
include(../sdk.cmake)
project(blink C CXX ASM)
-set(CMAKE_C_STANDARD 11)
-set(CMAKE_CXX_STANDARD 17)
pico_sdk_init()
-add_compile_options(-Wall
- -Wno-format # int != int32_t as far as the compiler is concerned because gcc has int32_t as long int
- -Wno-unused-function # we have some for the docs that aren't called
- -Wno-maybe-uninitialized
- )
+add_compile_options(-Wall)
add_executable(blink
blink.c
)
-# pull in common dependencies
target_link_libraries(blink pico_stdlib)
-
-# create map/bin/hex file etc.
pico_add_extra_outputs(blink)