summaryrefslogtreecommitdiff
path: root/sdk-blink/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sdk-blink/CMakeLists.txt')
-rw-r--r--sdk-blink/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/sdk-blink/CMakeLists.txt b/sdk-blink/CMakeLists.txt
new file mode 100644
index 0000000..c365501
--- /dev/null
+++ b/sdk-blink/CMakeLists.txt
@@ -0,0 +1,25 @@
+cmake_minimum_required(VERSION 3.12)
+
+include(../sdk.cmake)
+
+project(blink C CXX ASM)
+set(CMAKE_C_STANDARD 11)
+set(CMAKE_CXX_STANDARD 17)
+
+pico_sdk_init()
+
+add_compile_options(-Wall
+ -Wno-format # int != int32_t as far as the compiler is concerned because gcc has int32_t as long int
+ -Wno-unused-function # we have some for the docs that aren't called
+ -Wno-maybe-uninitialized
+ )
+
+add_executable(blink
+ blink.c
+ )
+
+# pull in common dependencies
+target_link_libraries(blink pico_stdlib)
+
+# create map/bin/hex file etc.
+pico_add_extra_outputs(blink)