summaryrefslogtreecommitdiff
path: root/prom-alertmanager/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'prom-alertmanager/debian/rules')
-rwxr-xr-xprom-alertmanager/debian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/prom-alertmanager/debian/rules b/prom-alertmanager/debian/rules
new file mode 100755
index 0000000..6b8773b
--- /dev/null
+++ b/prom-alertmanager/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+%:
+ dh $@
+
+override_dh_auto_configure:
+
+override_dh_auto_build:
+ make $(DEB_BUILD_ARCH)/alertmanager
+
+override_dh_auto_install:
+ install -d $$(pwd)/debian/tmp/usr/bin/
+ install -m 755 $$(pwd)/$(DEB_BUILD_ARCH)/alertmanager $$(pwd)/debian/tmp/usr/bin/prometheus-alertmanager
+ install -m 755 $$(pwd)/$(DEB_BUILD_ARCH)/amtool $$(pwd)/debian/tmp/usr/bin/amtool