summaryrefslogtreecommitdiff
path: root/prom-exporter-smokeping/debian/rules
diff options
context:
space:
mode:
authorChristian Pointner <equinox@spreadspace.org>2022-11-06 16:50:48 +0100
committerChristian Pointner <equinox@spreadspace.org>2022-11-06 16:50:48 +0100
commit3e4942f5d23a3329558f8c1b9dd501f89063d327 (patch)
treefbffcec58e99a15b527439cbed6b581aa8706491 /prom-exporter-smokeping/debian/rules
parentadd package for snmp exporter (diff)
add package for prometheus smokeping prober
Diffstat (limited to 'prom-exporter-smokeping/debian/rules')
-rwxr-xr-xprom-exporter-smokeping/debian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/prom-exporter-smokeping/debian/rules b/prom-exporter-smokeping/debian/rules
new file mode 100755
index 0000000..0ba3d90
--- /dev/null
+++ b/prom-exporter-smokeping/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+include /usr/share/dpkg/pkg-info.mk
+%:
+ dh $@
+
+override_dh_auto_configure:
+
+override_dh_auto_build:
+ make VERSION=$(DEB_VERSION_UPSTREAM) $(DEB_BUILD_ARCH)/smokeping_prober
+
+override_dh_auto_install:
+ install -d $$(pwd)/debian/tmp/usr/bin/
+ install -m 755 $$(pwd)/$(DEB_BUILD_ARCH)/smokeping_prober $$(pwd)/debian/tmp/usr/bin/prometheus-smokeping-prober
+
+override_dh_auto_clean:
+ make VERSION=$(DEB_VERSION_UPSTREAM) clean