summaryrefslogtreecommitdiff
path: root/prom-exporter-mosquitto/debian/rules
diff options
context:
space:
mode:
authorChristian Pointner <equinox@spreadspace.org>2023-12-17 23:33:59 +0100
committerChristian Pointner <equinox@spreadspace.org>2023-12-17 23:33:59 +0100
commitc102a213d6b43d57653703093f431ab8bcbb8cea (patch)
tree0c707d2beabde331c9a4e9ec806faff76f9cc3cc /prom-exporter-mosquitto/debian/rules
parentupdate prom-server package (diff)
add mosuqitto-exporter
Diffstat (limited to 'prom-exporter-mosquitto/debian/rules')
-rwxr-xr-xprom-exporter-mosquitto/debian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/prom-exporter-mosquitto/debian/rules b/prom-exporter-mosquitto/debian/rules
new file mode 100755
index 0000000..5f6b10e
--- /dev/null
+++ b/prom-exporter-mosquitto/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+include /usr/share/dpkg/pkg-info.mk
+%:
+ dh $@
+
+override_dh_auto_configure:
+
+override_dh_auto_build:
+ make VERSION=$(DEB_VERSION_UPSTREAM) $(DEB_BUILD_ARCH)/mosquitto-exporter
+
+override_dh_auto_install:
+ install -d $$(pwd)/debian/tmp/usr/bin/
+ install -m 755 $$(pwd)/$(DEB_BUILD_ARCH)/mosquitto-exporter $$(pwd)/debian/tmp/usr/bin/prometheus-mosquitto-exporter
+
+override_dh_auto_clean:
+ make VERSION=$(DEB_VERSION_UPSTREAM) clean