summaryrefslogtreecommitdiff
path: root/prom-exporter-modbus/debian/rules
diff options
context:
space:
mode:
authorChristian Pointner <equinox@spreadspace.org>2023-05-10 15:38:44 +0200
committerChristian Pointner <equinox@spreadspace.org>2023-05-10 15:38:44 +0200
commitf442a4ff9babe748b34dc61139428e828f3838fa (patch)
tree4fe63993ab4f2712f92b9a1d5c0773703bc3b9bc /prom-exporter-modbus/debian/rules
parentingnore arm64 subdirs (diff)
add modbus exporter
Diffstat (limited to 'prom-exporter-modbus/debian/rules')
-rwxr-xr-xprom-exporter-modbus/debian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/prom-exporter-modbus/debian/rules b/prom-exporter-modbus/debian/rules
new file mode 100755
index 0000000..91d9618
--- /dev/null
+++ b/prom-exporter-modbus/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+include /usr/share/dpkg/pkg-info.mk
+%:
+ dh $@
+
+override_dh_auto_configure:
+
+override_dh_auto_build:
+ make VERSION=$(DEB_VERSION_UPSTREAM) $(DEB_BUILD_ARCH)/modbus_exporter
+
+override_dh_auto_install:
+ install -d $$(pwd)/debian/tmp/usr/bin/
+ install -m 755 $$(pwd)/$(DEB_BUILD_ARCH)/modbus_exporter $$(pwd)/debian/tmp/usr/bin/prometheus-modbus-exporter
+
+override_dh_auto_clean:
+ make VERSION=$(DEB_VERSION_UPSTREAM) clean