summaryrefslogtreecommitdiff
path: root/prom-exporter-chrony/debian/rules
diff options
context:
space:
mode:
authorChristian Pointner <equinox@spreadspace.org>2023-05-26 17:36:27 +0200
committerChristian Pointner <equinox@spreadspace.org>2023-05-26 17:36:27 +0200
commit7b5f3b9030675b7bf16aa720062682698d5450fc (patch)
treee7acef5dc388d486d47e7a86880cd8fc38e1d0bf /prom-exporter-chrony/debian/rules
parentupdate all packages to latetst release (diff)
add package for chrony_exporter
Diffstat (limited to 'prom-exporter-chrony/debian/rules')
-rwxr-xr-xprom-exporter-chrony/debian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/prom-exporter-chrony/debian/rules b/prom-exporter-chrony/debian/rules
new file mode 100755
index 0000000..7d7b931
--- /dev/null
+++ b/prom-exporter-chrony/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+include /usr/share/dpkg/pkg-info.mk
+%:
+ dh $@
+
+override_dh_auto_configure:
+
+override_dh_auto_build:
+ make VERSION=$(DEB_VERSION_UPSTREAM) $(DEB_BUILD_ARCH)/chrony_exporter
+
+override_dh_auto_install:
+ install -d $$(pwd)/debian/tmp/usr/bin/
+ install -m 755 $$(pwd)/$(DEB_BUILD_ARCH)/chrony_exporter $$(pwd)/debian/tmp/usr/bin/prometheus-chrony-exporter
+
+override_dh_auto_clean:
+ make VERSION=$(DEB_VERSION_UPSTREAM) clean