summaryrefslogtreecommitdiff
path: root/prom-exporter-bind/debian/rules
diff options
context:
space:
mode:
authorChristian Pointner <equinox@spreadspace.org>2022-11-10 18:09:59 +0100
committerChristian Pointner <equinox@spreadspace.org>2022-11-10 18:09:59 +0100
commita52ae733a2140b1935c4ed519d590c43d63d1d94 (patch)
tree335d5da7caaa066b87b486f7ff1ce48cf944900c /prom-exporter-bind/debian/rules
parentadd package for prometheus smokeping prober (diff)
add bind-exporter
Diffstat (limited to 'prom-exporter-bind/debian/rules')
-rwxr-xr-xprom-exporter-bind/debian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/prom-exporter-bind/debian/rules b/prom-exporter-bind/debian/rules
new file mode 100755
index 0000000..189f74f
--- /dev/null
+++ b/prom-exporter-bind/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+include /usr/share/dpkg/pkg-info.mk
+%:
+ dh $@
+
+override_dh_auto_configure:
+
+override_dh_auto_build:
+ make VERSION=$(DEB_VERSION_UPSTREAM) $(DEB_BUILD_ARCH)/bind_exporter
+
+override_dh_auto_install:
+ install -d $$(pwd)/debian/tmp/usr/bin/
+ install -m 755 $$(pwd)/$(DEB_BUILD_ARCH)/bind_exporter $$(pwd)/debian/tmp/usr/bin/prometheus-bind-exporter
+
+override_dh_auto_clean:
+ make VERSION=$(DEB_VERSION_UPSTREAM) clean