summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules69
1 files changed, 0 insertions, 69 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index b0480fc..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,69 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- ./configure --prefix=/usr --sysconfdir=/etc --no-manpage --examplesdir=/usr/share/rhdropbox/examples
- touch configure-stamp
-
-build: build-stamp
-
-build-stamp: configure-stamp
- dh_testdir
-
- $(MAKE)
-
- touch $@
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
-
- # Add here commands to clean up after the build process.
- $(MAKE) --directory=$(CURDIR) distclean
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_installdirs
-
- # Add here commands to install the package into debian/rhdropbox.
- $(MAKE) DESTDIR=$(CURDIR)/debian/rhdropbox install
- # Fix unusual path:
- mv debian/rhdropbox/usr/share/rhdropbox/examples/rhdropbox debian/rhdropbox/usr/share/rhdropbox/examples/config
- echo "example configurations can be found at /usr/share/rhdropbox/examples/config" > debian/rhdropbox/etc/rhdropbox/README
-
-# Build architecture-independent files here.
-binary-indep: install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: install
- dh_testdir
- dh_testroot
- dh_installdocs
- dh_installinit
- dh_installman doc/rhdropbox.8
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure