summaryrefslogtreecommitdiff
path: root/helm/debian/rules
diff options
context:
space:
mode:
authorChristian Pointner <equinox@spreadspace.org>2022-08-22 02:12:39 +0200
committerChristian Pointner <equinox@spreadspace.org>2022-08-22 02:12:39 +0200
commit75ff356779f7d3791ef97b2669e5ca1d80cbed3a (patch)
treebd6178f546f03d93ef69cce7899303e9d6df124b /helm/debian/rules
parentfixup! add cri-tools 1.24 (diff)
add package for helm
Diffstat (limited to 'helm/debian/rules')
-rwxr-xr-xhelm/debian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/helm/debian/rules b/helm/debian/rules
new file mode 100755
index 0000000..52d22fd
--- /dev/null
+++ b/helm/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+include /usr/share/dpkg/pkg-info.mk
+%:
+ dh $@
+
+override_dh_auto_configure:
+
+override_dh_auto_build:
+ make VERSION=$(DEB_VERSION_UPSTREAM) $(DEB_BUILD_ARCH)/helm
+
+override_dh_auto_install:
+ install -d $$(pwd)/debian/tmp/usr/bin/
+ install -m 755 $$(pwd)/$(DEB_BUILD_ARCH)/helm $$(pwd)/debian/tmp/usr/bin/helm
+
+override_dh_auto_clean:
+ make VERSION=$(DEB_VERSION_UPSTREAM) clean