summaryrefslogtreecommitdiff
path: root/grype/debian/rules
diff options
context:
space:
mode:
authorChristian Pointner <equinox@spreadspace.org>2024-03-28 19:16:56 +0100
committerChristian Pointner <equinox@spreadspace.org>2024-03-28 19:16:56 +0100
commitc73d74ab7b01d5270a62ae9bb18da1dd1fc6039f (patch)
treef23cf252f629b7b4e939bfcd086d77edc2fccd13 /grype/debian/rules
parentbump k9s to 0.32.3 (diff)
add package for grype
Diffstat (limited to 'grype/debian/rules')
-rwxr-xr-xgrype/debian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/grype/debian/rules b/grype/debian/rules
new file mode 100755
index 0000000..4434037
--- /dev/null
+++ b/grype/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+include /usr/share/dpkg/pkg-info.mk
+%:
+ dh $@
+
+override_dh_auto_configure:
+
+override_dh_auto_build:
+ make VERSION=$(DEB_VERSION_UPSTREAM) $(DEB_BUILD_ARCH)/grype
+
+override_dh_auto_install:
+ install -d $$(pwd)/debian/tmp/usr/bin/
+ install -m 755 $$(pwd)/$(DEB_BUILD_ARCH)/grype $$(pwd)/debian/tmp/usr/bin/grype
+
+override_dh_auto_clean:
+ make VERSION=$(DEB_VERSION_UPSTREAM) clean