summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorChristian Pointner <equinox@anytun.org>2009-02-10 01:48:42 +0000
committerChristian Pointner <equinox@anytun.org>2009-02-10 01:48:42 +0000
commit84d2f627359db0eaf11bd9a8087466c6523cfa35 (patch)
treeb2c06cbcf24dd17974e4257e1d7c4246b011ab12 /openwrt
parentadded install target to make file (diff)
Kamikaze Makefile cleanup
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/kamikaze/uanytun/Makefile34
1 files changed, 17 insertions, 17 deletions
diff --git a/openwrt/kamikaze/uanytun/Makefile b/openwrt/kamikaze/uanytun/Makefile
index 784fc94..809ed89 100644
--- a/openwrt/kamikaze/uanytun/Makefile
+++ b/openwrt/kamikaze/uanytun/Makefile
@@ -35,30 +35,30 @@ define Package/uanytun
endef
define Build/Configure
- (cd $(PKG_BUILD_DIR)/src; \
- touch include.mk; \
+ (cd $(PKG_BUILD_DIR)/src; \
+ touch include.mk; \
ln -s linux/tun.c . \
- )
+ )
endef
define Build/Compile
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR)/src \
- $(TARGET_CONFIGURE_OPTS) \
- TARGET=Linux \
- CFLAGS="$(TARGET_CFLAGS) -DUSE_SSL_CRYPTO -I$(STAGING_DIR)/usr/include" \
- LDFLAGS="$(TARGET_LDFLAGS) -ldl -lcrypto"
- $(STRIP) $(PKG_BUILD_DIR)/src/uanytun
+ rm -rf $(PKG_INSTALL_DIR)
+ mkdir -p $(PKG_INSTALL_DIR)
+ $(MAKE) -C $(PKG_BUILD_DIR)/src \
+ $(TARGET_CONFIGURE_OPTS) \
+ TARGET=Linux \
+ CFLAGS="$(TARGET_CFLAGS) -DUSE_SSL_CRYPTO -I$(STAGING_DIR)/usr/include" \
+ LDFLAGS="$(TARGET_LDFLAGS) -ldl -lcrypto"
+ $(STRIP) $(PKG_BUILD_DIR)/src/uanytun
endef
define Package/uanytun/install
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_DATA) ./files/uanytun.config $(1)/etc/config/uanytun
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/uanytun $(1)/usr/sbin/
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/uanytun.init $(1)/etc/init.d/uanytun
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_DATA) ./files/uanytun.config $(1)/etc/config/uanytun
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/uanytun $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/uanytun.init $(1)/etc/init.d/uanytun
endef