summaryrefslogtreecommitdiff
path: root/gentoo-linux/net-misc/uanytun/uanytun-0.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo-linux/net-misc/uanytun/uanytun-0.3.2.ebuild')
-rw-r--r--gentoo-linux/net-misc/uanytun/uanytun-0.3.2.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/gentoo-linux/net-misc/uanytun/uanytun-0.3.2.ebuild b/gentoo-linux/net-misc/uanytun/uanytun-0.3.2.ebuild
index 84d6a35..ad59b7a 100644
--- a/gentoo-linux/net-misc/uanytun/uanytun-0.3.2.ebuild
+++ b/gentoo-linux/net-misc/uanytun/uanytun-0.3.2.ebuild
@@ -4,7 +4,7 @@
inherit eutils
-DESCRIPTION="tiny VPN daemon using Secure Anycast Tunneling"
+DESCRIPTION="Tiny VPN daemon using Secure Anycast Tunneling"
HOMEPAGE="http://anytun.org/"
SRC_URI="http://anytun.org/download/${P}.tar.gz"
@@ -14,7 +14,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="examples gcrypt"
RDEPEND="gcrypt? ( dev-libs/libgcrypt )
- !gcrypt? ( dev-libs/openssl )"
+ !gcrypt? ( dev-libs/openssl )"
DEPEND="${RDEPEND}
app-text/asciidoc"
@@ -23,9 +23,9 @@ S=${S}/src
src_compile() {
local myconf
use gcrypt || myconf="--use-ssl-crypto"
- use examples && myconf="${myconf} --examplesdir=/usr/share/doc/${PF}/examples/etc"
- use examples || myconf="${myconf} --no-examples"
- econf --ebuild-compat ${myconf} || die "configure failed"
+ use examples && myconf="${myconf} --examplesdir=/usr/share/doc/${PF}/examples/etc" \
+ || myconf="${myconf} --no-examples"
+ econf --ebuild-compat ${myconf}
einfo "Building executables"
emake || die "make failed"
@@ -36,10 +36,10 @@ src_compile() {
src_install() {
emake install DESTDIR="${D}" || die "make install failed"
- rm -Rf ${D}/etc/init.d
+ rm -Rf "${D}"/etc/init.d
#as long as README just contains path to examples, only install it with examples
- use examples || rm ${D}/etc/${PN}/README
-
+ use examples || rm -f "${D}"/etc/${PN}/README
+
newinitd "${FILESDIR}/${PN}-0.3.1.init" ${PN} || die "failed to copy/install initrd script"
cd ../
@@ -58,9 +58,9 @@ pkg_config() {
pkg_postinst() {
enewgroup uanytun
enewuser uanytun -1 -1 /var/run/ uanytun
- einfo "Note that each VPN gets its own directory under /etc/${PN}/"
- einfo "(see examples provided with the package)"
- einfo "Use the following command to create gentoo-style"
- einfo "uanytun.{VPN} initrd scripts for each VPN"
- einfo "# ln -s /etc/init.d/${PN} /etc/init.d/${PN}.client1"
+ elog "Note that each VPN gets its own directory under /etc/${PN}/"
+ elog "(see examples provided with the package)"
+ elog "Use the following command to create gentoo-style"
+ elog "uanytun.{VPN} initrd scripts for each VPN"
+ elog "# ln -s /etc/init.d/${PN} /etc/init.d/${PN}.client1"
}