summaryrefslogtreecommitdiff
path: root/gentoo-linux/net-misc/anytun/anytun-0.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo-linux/net-misc/anytun/anytun-0.3.2.ebuild')
-rw-r--r--gentoo-linux/net-misc/anytun/anytun-0.3.2.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/gentoo-linux/net-misc/anytun/anytun-0.3.2.ebuild b/gentoo-linux/net-misc/anytun/anytun-0.3.2.ebuild
index 49aadfd..d7f850b 100644
--- a/gentoo-linux/net-misc/anytun/anytun-0.3.2.ebuild
+++ b/gentoo-linux/net-misc/anytun/anytun-0.3.2.ebuild
@@ -24,9 +24,9 @@ S=${S}/src
src_compile() {
local myconf
use gcrypt || myconf="--use-ssl-crypto"
- use examples && myconf="${myconf} --examplesdir=/usr/share/doc/${PF}/examples/etc"
- use examples || myconf="${myconf} --no-examples"
- econf --ebuild-compat ${myconf} || die "configure failed"
+ use examples && myconf="${myconf} --examplesdir=/usr/share/doc/${PF}/examples/etc" \
+ || myconf="${myconf} --no-examples"
+ econf --ebuild-compat ${myconf}
einfo "Building executables"
emake || die "make failed"
@@ -37,9 +37,9 @@ src_compile() {
src_install() {
emake install DESTDIR="${D}" || die "make install failed"
- rm -Rf ${D}/etc/init.d
+ rm -Rf "${D}"/etc/init.d
#as long as README just contains path to examples, only install it with examples
- use examples || rm ${D}/etc/${PN}/README
+ use examples || rm -f "${D}"/etc/${PN}/README
keepdir /var/run/anytun || die "failed to mkdir"
keepdir /var/run/anytun-controld || die "failed to mkdir"
@@ -64,12 +64,12 @@ pkg_config() {
pkg_postinst() {
enewgroup anytun
enewuser anytun -1 -1 /var/run/anytun anytun
- einfo "Please refer to the README file regarding the syntax of the /etc/${PN}/"
- einfo "configuration files or see examples provided with the package"
- einfo "You can use gentoo-style ${PN}.{VPN} initrd scripts to start "
- einfo "VPNs separately. Just symlink to the initscript, e.g.:"
- einfo "# ln -s /etc/init.d/${PN} /etc/init.d/${PN}.client1"
- einfo
- einfo "You can disect anytun traffic using wireshark by plugging the script"
- einfo " /usr/share/${P}/wireshark-lua/satp.lua into wireshark"
+ elog "Please refer to the README file regarding the syntax of the /etc/${PN}/"
+ elog "configuration files or see examples provided with the package"
+ elog "You can use gentoo-style ${PN}.{VPN} initrd scripts to start "
+ elog "VPNs separately. Just symlink to the initscript, e.g.:"
+ elog "# ln -s /etc/init.d/${PN} /etc/init.d/${PN}.client1"
+ elog
+ elog "You can disect anytun traffic using wireshark by plugging the script"
+ elog " /usr/share/${P}/wireshark-lua/satp.lua into wireshark"
}