summaryrefslogtreecommitdiff
path: root/gentoo-linux/net-misc/anytun/anytun-0.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo-linux/net-misc/anytun/anytun-0.3.1.ebuild')
-rw-r--r--gentoo-linux/net-misc/anytun/anytun-0.3.1.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/gentoo-linux/net-misc/anytun/anytun-0.3.1.ebuild b/gentoo-linux/net-misc/anytun/anytun-0.3.1.ebuild
index 077d6f8..920a9b5 100644
--- a/gentoo-linux/net-misc/anytun/anytun-0.3.1.ebuild
+++ b/gentoo-linux/net-misc/anytun/anytun-0.3.1.ebuild
@@ -17,11 +17,13 @@ DEPEND=">=dev-libs/boost-1.35
!gcrypt? ( >=dev-libs/openssl-0.9.6 )
doc? ( <app-text/asciidoc-8.5.0 )" # asciidoc a2x <= 8.5.0 requires the -L switch
RDEPEND="${DEPEND}"
+S="${WORKDIR}/${P}/src"
src_compile() {
- cd "${S}/src"
local myconf=""
use gcrypt || myconf="${myconf} --use-ssl-crypto"
+ # anytun's configure right now only takes 1! option (no --prefix etc), so econf would be too
+ # much for your little script and the build would fail
#econf ${myconf} || die "configure failed"
./configure ${myconf} || die "configure failed"
emake || die "make failed"
@@ -32,26 +34,23 @@ src_compile() {
}
src_install() {
- cd "${S}/src"
+ local pkgroot="${WORKDIR}/${P}"
dosbin anytun || die "failed to copy/install an executable"
dobin anytun-config anytun-controld anytun-showtables anytun-nosync || die "failed to copy/install an executable"
newinitd "${FILESDIR}/${PN}-0.3.1.init" anytun || die "failed to copy/install initrd script"
- #insinto /etc/default/
- #doins ${S}/etc/default/* || die "failed to copy/install defaults"
insinto /usr/share/${P}/wireshark-lua/
- doins ${S}/wireshark-lua/* || die "failed to install wireshark-lua contrib script"
+ doins ${pkgroot}/wireshark-lua/* || die "failed to install wireshark-lua contrib script"
dodir /var/run/anytun || die "failed to mkdir"
keepdir /var/run/anytun
dodir /var/run/anytun-controld || die "failed to mkdir"
keepdir /var/run/anytun-controld
if use examples; then
insinto /usr/share/doc/${PF}/etc-anytun-examples/
- doins -r ${S}/etc/anytun/* || die "failed to install examples"
+ doins -r ${pkgroot}/etc/anytun/* || die "failed to install examples"
fi
if use doc; then
- cd ${S}
- dodoc AUTHORS ChangeLog LICENSE README || die "failed to install docs"
- cd ${S}/src/man/
+ dodoc ${pkgroot}/AUTHORS ${pkgroot}/ChangeLog ${pkgroot}/LICENSE ${pkgroot}/README || die "failed to install docs"
+ cd ${S}/man/
doman anyrtpproxy.8 anytun-config.8 anytun-controld.8 anytun-showtables.8 anytun.8 || die "failed to install manpages"
prepallman || die "failed to prep manpages"
fi
@@ -73,14 +72,14 @@ pkg_postinst() {
einfo " /usr/share/doc/${PF}/etc-anytun-examples/"
einfo "You can copy them to /etc/anytun using"
einfo "> emerge --config anytun"
- einfo ""
+ einfo
else
einfo "You did not install examples."
einfo "If you need example configs to get you started, "
einfo "you can extract them from the anytun.tar.gz or "
einfo "e.g.: tar xzv --strip-components 3 -f ${DISTDIR}/${P}.tar.gz -C /etc/anytun/ ${P}/etc/anytun"
einfo "or visit the anytun wiki online"
- einfo ""
+ einfo
fi
einfo "Note that each VPN gets it's own directory under /etc/anytun/"
einfo "You can either add tunnels to /etc/anytun/autostart and"
@@ -88,12 +87,12 @@ pkg_postinst() {
einfo "Or you can forget the autostart file and create"
einfo "gentoo-style anytun.{VPN} initrd scripts for each VPN"
einfo "e.g.> ln -s /etc/init.d/anytun /etc/init.d/anytun.client1"
- einfo ""
+ einfo
einfo "Don't forget to "
einfo "> rc-update add anytun default"
einfo "or"
einfo "> rc-update add anytun.client1 default"
- einfo ""
+ einfo
einfo "You can disect anytun traffic using wireshark by plugging the script"
einfo "/usr/share/${P}/wireshark-lua/satp.lua into wireshark"
}