summaryrefslogtreecommitdiff
path: root/whawty-auth/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'whawty-auth/debian/rules')
-rwxr-xr-xwhawty-auth/debian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/whawty-auth/debian/rules b/whawty-auth/debian/rules
index 926c4d3..cb55cec 100755
--- a/whawty-auth/debian/rules
+++ b/whawty-auth/debian/rules
@@ -6,8 +6,8 @@ include /usr/share/dpkg/pkg-info.mk
override_dh_auto_configure:
override_dh_auto_build:
- make VERSION=$(DEB_VERSION_UPSTREAM) $(DEB_BUILD_ARCH)/whawty-auth
- make VERSION=$(DEB_VERSION_UPSTREAM) $(DEB_BUILD_ARCH)/pam/pam_whawty.so
+ make VERSION=$(shell echo $(DEB_VERSION_UPSTREAM) | sed 's#~rc#-rc#') $(DEB_BUILD_ARCH)/whawty-auth
+ make VERSION=$(shell echo $(DEB_VERSION_UPSTREAM) | sed 's#~rc#-rc#') $(DEB_BUILD_ARCH)/pam/pam_whawty.so
override_dh_auto_install:
install -d $$(pwd)/debian/tmp/usr/bin/
@@ -16,4 +16,4 @@ override_dh_auto_install:
install -m 644 $$(pwd)/$(DEB_BUILD_ARCH)/pam/pam_whawty.so $$(pwd)/debian/tmp/lib/$(DEB_HOST_MULTIARCH)/security/
override_dh_auto_clean:
- make VERSION=$(DEB_VERSION_UPSTREAM) clean
+ make VERSION=$(shell echo $(DEB_VERSION_UPSTREAM) | sed 's#~rc#-rc#') clean