summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorChristian Pointner <equinox@spreadspace.org>2014-09-04 00:15:11 +0200
committerChristian Pointner <equinox@spreadspace.org>2014-09-04 00:15:11 +0200
commitd748d89fe0dd0f85c47519d51ffcafbf0a3d8b75 (patch)
treed03957649f3e51c23c2f434634b838b2e2cf0777 /src
parentupdated options parser (diff)
removed useless sysexec
Diffstat (limited to 'src')
-rw-r--r--src/Makefile1
-rw-r--r--src/sysexec.c226
-rw-r--r--src/sysexec.h51
3 files changed, 0 insertions, 278 deletions
diff --git a/src/Makefile b/src/Makefile
index e5c22e4..4cc4b3c 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -38,7 +38,6 @@ C_OBJS := log.o \
options.o \
slist.o \
string_list.o \
- sysexec.o \
sydra.o
C_SRCS := $(C_OBJS:%.o=%.c)
diff --git a/src/sysexec.c b/src/sysexec.c
deleted file mode 100644
index 2d740ce..0000000
--- a/src/sysexec.c
+++ /dev/null
@@ -1,226 +0,0 @@
-/*
- * sydra
- *
- * sydra is a toolbox which allows you to set up multiple bidirectional
- * Video/Audio streams from external locations.
- * sydra has been written to be used for the Elevate Festival in Graz
- * Austria in order to involve external locations to present themselves
- * at the festival.
- * Sydra is based on GStreamer and is written in C.
- *
- *
- * Copyright (C) 2014 Christian Pointner <equinox@helsinki.at>
- *
- * This file is part of sydra.
- *
- * sydra is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * any later version.
- *
- * sydra is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with sydra. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include "datatypes.h"
-
-#include <unistd.h>
-#include <sys/types.h>
-#include <sys/stat.h>
-#include <fcntl.h>
-#include <errno.h>
-#include <sys/wait.h>
-#include <sys/select.h>
-#include <stdlib.h>
-#include <string.h>
-
-#include "sysexec.h"
-#include "log.h"
-
-char** dup_ptrptr(char* const ptrptr[])
-{
- if(!ptrptr)
- return NULL;
-
- int n = 0;
- while(ptrptr[n])
- n++;
-
- char** my_ptrptr;
- my_ptrptr = malloc((n+1)*sizeof(char*));
- if(!my_ptrptr)
- return NULL;
-
- int i;
- for(i = 0; i < n; ++i) {
- my_ptrptr[i] = strdup(ptrptr[i]);
- if(!my_ptrptr[i]) {
- i--;
- for(; i >= 0; --i)
- free(my_ptrptr[i]);
-
- free(my_ptrptr);
- return NULL;
- }
- }
-
- my_ptrptr[n] = NULL;
-
- return my_ptrptr;
-}
-
-void free_ptrptr(char** ptrptr)
-{
- if(!ptrptr)
- return;
-
- int i;
- for(i = 0; ptrptr[i]; ++i)
- free(ptrptr[i]);
-
- free(ptrptr);
-}
-
-child_t* new_child(const char* script, char* const argv[], char* const evp[])
-{
- child_t* new_child;
-
- new_child = malloc(sizeof(child_t));
- if(!new_child)
- return NULL;
-
- new_child->pid_ = -1;
- new_child->err_fd_ = -1;
- new_child->script_ = strdup(script);
- if(!new_child->script_) {
- free(new_child);
- return NULL;
- }
-
- new_child->argv_ = dup_ptrptr(argv);
- if(!new_child->argv_) {
- free(new_child->script_);
- free(new_child);
- return NULL;
-
- }
-
- new_child->evp_ = dup_ptrptr(evp);
- if(!new_child->evp_) {
- free_ptrptr(new_child->argv_);
- free(new_child->script_);
- free(new_child);
- return NULL;
- }
- return new_child;
-}
-
-void free_child(child_t* child)
-{
- if(!child)
- return;
-
- free_ptrptr(child->argv_);
- free_ptrptr(child->evp_);
- if(child->script_)
- free(child->script_);
- if(child->err_fd_ >= 0) close(child->err_fd_);
- free(child);
-}
-
-child_t* sydra_exec(const char* script, char* const argv[], char* const evp[])
-{
- if(!script)
- return NULL;
-
- child_t* child = new_child(script, argv, evp);
- if(!child)
- return NULL;
-
- int pipefd[2];
- if(pipe(pipefd) == -1) {
- log_printf(ERROR, "executing script '%s' failed: pipe() error: %s", child->script_, strerror(errno)); // TODO: thread safe strerror
- free_child(child);
- return NULL;
- }
-
- pid_t pid;
- pid = fork();
- if(pid == -1) {
- log_printf(ERROR, "executing script '%s' failed: fork() error: %s", child->script_, strerror(errno)); // TODO: thread safe strerror
- close(pipefd[0]);
- close(pipefd[1]);
- free_child(child);
- return NULL;
- }
-
- if(!pid) {
- int fd;
- for (fd=getdtablesize();fd>=0;--fd) // close all file descriptors
- if(fd != pipefd[1]) close(fd);
-
- fd = open("/dev/null",O_RDWR); // stdin
- if(fd == -1)
- log_printf(WARNING, "can't open stdin");
- else {
- if(dup(fd) == -1) // stdout
- log_printf(WARNING, "can't open stdout");
- if(dup(fd) == -1) // stderr
- log_printf(WARNING, "can't open stderr");
- }
- execve(child->script_, child->argv_, child->evp_);
- // if execve returns, an error occurred, but logging doesn't work
- // because we closed all file descriptors, so just write errno to
- // pipe and call exit
- int len = write(pipefd[1], (void*)(&errno), sizeof(errno));
- if(len) exit(-1);
- exit(-1);
- }
- close(pipefd[1]);
-
- child->pid_ = pid;
- child->err_fd_ = pipefd[0];
-
- log_printf(INFO, "called script '%s' with pid %d", child->script_, child->pid_);
-
- return child;
-}
-
-int sydra_waitpid(child_t* child, int* status_return)
-{
- int status = 0;
- pid_t pid = waitpid(child->pid_, &status, WNOHANG);
- if(!pid || (pid < 0 && errno == ECHILD))
- return 0;
- if(pid < 0) {
- log_printf(ERROR, "waitpid returned with error: %s", strerror(errno)); // TODO: thread safe strerror
- return pid;
- }
-
- fd_set rfds;
- FD_ZERO(&rfds);
- FD_SET(child->err_fd_, &rfds);
- struct timeval tv = { 0 , 0 };
- if(select(child->err_fd_+1, &rfds, NULL, NULL, &tv) == 1) {
- int err = 0;
- if(read(child->err_fd_, (void*)(&err), sizeof(err)) >= sizeof(err)) {
- log_printf(INFO, "script '%s' exec() error: %s", child->script_, strerror(err)); // TODO: thread safe strerror
- return -1;
- }
- }
- if(WIFEXITED(status))
- log_printf(INFO, "script '%s' (pid %d) returned %d", child->script_, child->pid_, WEXITSTATUS(status));
- else if(WIFSIGNALED(status))
- log_printf(INFO, "script '%s' (pid %d) terminated after signal %d", child->script_, child->pid_, WTERMSIG(status));
- else
- log_printf(INFO, "executing script '%s' (pid %d): unkown error", child->script_, child->pid_);
-
- if(status_return) *status_return = status;
-
- return 1;
-}
diff --git a/src/sysexec.h b/src/sysexec.h
deleted file mode 100644
index dc00bb6..0000000
--- a/src/sysexec.h
+++ /dev/null
@@ -1,51 +0,0 @@
-/*
- * sydra
- *
- * sydra is a toolbox which allows you to set up multiple bidirectional
- * Video/Audio streams from external locations.
- * sydra has been written to be used for the Elevate Festival in Graz
- * Austria in order to involve external locations to present themselves
- * at the festival.
- * Sydra is based on GStreamer and is written in C.
- *
- *
- * Copyright (C) 2014 Christian Pointner <equinox@helsinki.at>
- *
- * This file is part of sydra.
- *
- * sydra is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * any later version.
- *
- * sydra is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with sydra. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#ifndef SYDRA_sysexec_h_INCLUDED
-#define SYDRA_sysexec_h_INCLUDED
-
-#include <sys/types.h>
-#include "options.h"
-
-struct child_struct {
- pid_t pid_;
- char* script_;
- int err_fd_;
- char** argv_;
- char** evp_;
-};
-typedef struct child_struct child_t;
-
-child_t* new_child(const char* script, char* const argv[], char* const evp[]);
-void free_child(child_t* child);
-
-child_t* sydra_exec(const char* script, char* const argv[], char* const evp[]);
-int sydra_waitpid(child_t* child, int* status);
-
-#endif