summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorChristian Pointner <equinox@spreadspace.org>2014-09-04 22:59:16 +0200
committerChristian Pointner <equinox@spreadspace.org>2014-09-04 22:59:16 +0200
commitb93cf68ccf41e62d3e4dd76b8924aeb5d16ee481 (patch)
tree4ebafcf9b478ad06797e0984e793d6c2fbc9427b /src
parentpipeline works now - however recording is still disabled.. (diff)
removed custom sighandler code in favor of glib based signal handling
Diffstat (limited to 'src')
-rw-r--r--src/Makefile1
-rw-r--r--src/sig_handler.c113
-rw-r--r--src/sig_handler.h39
-rw-r--r--src/sydra.c20
4 files changed, 15 insertions, 158 deletions
diff --git a/src/Makefile b/src/Makefile
index 4cc4b3c..1ee2157 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -34,7 +34,6 @@ endif
EXECUTABLE := sydra
C_OBJS := log.o \
- sig_handler.o \
options.o \
slist.o \
string_list.o \
diff --git a/src/sig_handler.c b/src/sig_handler.c
deleted file mode 100644
index 9a77d39..0000000
--- a/src/sig_handler.c
+++ /dev/null
@@ -1,113 +0,0 @@
-/*
- * sydra
- *
- * sydra is a toolbox which allows you to set up multiple bidirectional
- * Video/Audio streams from external locations.
- * sydra has been written to be used for the Elevate Festival in Graz
- * Austria in order to involve external locations to present themselves
- * at the festival.
- * Sydra is based on GStreamer and is written in C.
- *
- *
- * Copyright (C) 2014 Christian Pointner <equinox@helsinki.at>
- *
- * This file is part of sydra.
- *
- * sydra is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * any later version.
- *
- * sydra is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with sydra. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include "datatypes.h"
-
-#include "log.h"
-
-#include "sig_handler.h"
-
-#include <glib.h>
-#include <errno.h>
-
-static GThread *signal_thread;
-
-void signal_init()
-{
- sigset_t signal_set;
-
- sigemptyset(&signal_set);
- sigaddset(&signal_set, SIGINT);
- sigaddset(&signal_set, SIGQUIT);
- sigaddset(&signal_set, SIGHUP);
- sigaddset(&signal_set, SIGTERM);
- sigaddset(&signal_set, SIGUSR1);
- sigaddset(&signal_set, SIGUSR2);
-
- pthread_sigmask(SIG_BLOCK, &signal_set, NULL);
-}
-
-static gpointer signal_thread_func(gpointer data)
-{
- GMainLoop *loop = (GMainLoop *)data;
-
- struct timespec timeout;
- sigset_t signal_set;
- int sig_num;
- for(;;) {
- sigemptyset(&signal_set);
- sigaddset(&signal_set, SIGINT);
- sigaddset(&signal_set, SIGQUIT);
- sigaddset(&signal_set, SIGHUP);
- sigaddset(&signal_set, SIGTERM);
- sigaddset(&signal_set, SIGUSR1);
- sigaddset(&signal_set, SIGUSR2);
- timeout.tv_sec = 1;
- timeout.tv_nsec = 0;
- sig_num = sigtimedwait(&signal_set, NULL, &timeout);
- if(sig_num == -1) {
- if(errno != EINTR && errno != EAGAIN) {
- log_printf(ERROR, "sigwait failed with error: %d, signal handling will be disabled", errno);
- break;
- }
- } else {
- switch(sig_num) {
- case SIGTERM:
- case SIGINT:
- case SIGQUIT: {
- log_printf(NOTICE, "signal %d received, exiting", sig_num);
- g_main_loop_quit(loop);
- break;
- }
- default: {
- log_printf(NOTICE, "signal %d received, ignoring", sig_num);
- break;
- }
- }
- }
- }
-
- return NULL;
-}
-
-int signal_start(GMainLoop *loop)
-{
- g_assert(!signal_thread);
-
- signal_thread = g_thread_new("sig_handler", signal_thread_func, loop);
- if(!signal_thread)
- return -1;
-
- return 0;
-}
-
-void signal_stop()
-{
- // nothing yet..
-}
diff --git a/src/sig_handler.h b/src/sig_handler.h
deleted file mode 100644
index 739cdc2..0000000
--- a/src/sig_handler.h
+++ /dev/null
@@ -1,39 +0,0 @@
-/*
- * sydra
- *
- * sydra is a toolbox which allows you to set up multiple bidirectional
- * Video/Audio streams from external locations.
- * sydra has been written to be used for the Elevate Festival in Graz
- * Austria in order to involve external locations to present themselves
- * at the festival.
- * Sydra is based on GStreamer and is written in C.
- *
- *
- * Copyright (C) 2014 Christian Pointner <equinox@helsinki.at>
- *
- * This file is part of sydra.
- *
- * sydra is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * any later version.
- *
- * sydra is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with sydra. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#ifndef SYDRA_sig_handler_h_INCLUDED
-#define SYDRA_sig_handler_h_INCLUDED
-
-#include <glib.h>
-
-void signal_init();
-int signal_start(GMainLoop *loop);
-void signal_stop();
-
-#endif
diff --git a/src/sydra.c b/src/sydra.c
index 747d605..b45ef3c 100644
--- a/src/sydra.c
+++ b/src/sydra.c
@@ -35,15 +35,25 @@
#include <sys/select.h>
#include <time.h>
+#include <glib.h>
+#include <glib-unix.h>
#include <gst/gst.h>
#include "datatypes.h"
#include "options.h"
#include "string_list.h"
#include "log.h"
-#include "sig_handler.h"
#include "daemon.h"
+static gboolean sig_handler_terminate(gpointer user_data)
+{
+ GMainLoop *loop = (GMainLoop *)user_data;
+
+ log_printf(NOTICE, "signal received, closing application");
+ g_main_loop_quit(loop);
+ return TRUE;
+}
+
static gboolean bus_call(GstBus *bus, GstMessage *msg, gpointer data)
{
GMainLoop *loop = (GMainLoop *)data;
@@ -161,7 +171,7 @@ int main_loop(options_t* opt)
int rtcp_port_a = opt->rtp_port_base_ + 300;
char* sender_desc;
- int slen = asprintf(&sender_desc, "rtpbin name=rtpbin \
+ int slen = asprintf(&sender_desc, "rtpbin name=rtpbin \
%s ! tee name=vt \
vt. ! queue silent=true ! %s ! tee name=cvt \
cvt. ! %s ! rtpbin.send_rtp_sink_0 \
@@ -202,9 +212,10 @@ int main_loop(options_t* opt)
log_printf(INFO, "Set State: Playing");
gst_element_set_state(pipeline, GST_STATE_PLAYING);
- signal_start(loop);
+ g_unix_signal_add(SIGHUP, sig_handler_terminate, loop);
+ g_unix_signal_add(SIGINT, sig_handler_terminate, loop);
+ g_unix_signal_add(SIGTERM, sig_handler_terminate, loop);
g_main_loop_run(loop);
- signal_stop();
log_printf(NOTICE, "Stopping pipeline");
gst_element_set_state (pipeline, GST_STATE_NULL);
@@ -310,7 +321,6 @@ int main(int argc, char* argv[])
fclose(pid_file);
}
- signal_init();
gst_init(NULL, NULL);
const gchar *nano_str;
guint major, minor, micro, nano;